h1

JAGS 2.0.0 for Ubuntu 10.04

April 29, 2010

I built a package of JAGS 2.0.0 for Ubuntu 10.04 64 bit. This was just a quick rebuild from the upstream Debian Sid source. It seems to work fine. It is available here . Please let me know if you have any issues with it. I plan on tracking Ubuntu 10.04 64 bit on my laptop until Squeeze is released and then moving back to Debian. Until then I plan to keep this package up-to-date for Ubuntu.

EDIT: rjags has not yet been updated for JAGS 2.0.0, so if you want to continue to use rjags, you should hang tight with JAGS 1.0.4 for the time being.

2nd EDIT: I already got sick of Ubuntu and am back on Debian testing (and will be until Squeeze becomes stable then I will follow stable). So while I won’t be pulling my JAGS package, I won’t be updating it either. Sorry.

Also, I’ve noticed a lot of people seem to be coming here to figure out how to set up WinBUGS or OpenBUGS on their Mac. If possible, I’d like to encourage you to use JAGS. It really does work great, is cross-platform, and open source.

3rd EDIT (May 7th 2010): JAGS 2.0.0 has now hit Squeeze and this means that rjags on CRAN is presently broken. However, you can grab the rjags tarball from sourceforge here and install it by running the following code.


R CMD INSTALL rjags_2.0.0-2.tar.gz

Restart R and you can now load the rjags library again. Thanks to Dirk Eddelbuettel for the tip that a compatible version of rjags was living on Sourceforge.

4th EDIT (May 21st, 2010): JAGS 2.1.0 and rjags 2.1.0 have been released. rjags 2.1.0 is now on CRAN so you no longer need to install rjags from Sourceforge. I will not be updating the package for Ubuntu, as I am on Debian testing, sorry.

Advertisements

2 comments

  1. Glad to hear that the current rjags has not been updated to JAGS 2.0.0. I posted a message on the R Debian list showing my failed attempt to (re)-install rjags with the current Debian sid jags package.


    • Hi Seb,
      I follow Martyn Plummer’s blog to keep up-to-date with JAGS news. He mentions here that rjags will be updated soon. I’d recommend uninstalling 2.0.0 and just grabbing 1.0.4 from Squeeze while it’s still there until Martyn updates rjags.



Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: